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1 ALEPHADM Overview

The ALEPH integrated library system can be adapted to very different library policies
and needs. Most of the configuration setup is made in ALEPH tables. The
ALEPHADM module enables you to access and modify these tables through a
Windows interface. Almost any parameter that can be set in ALEPH tables can be
reset, controlled and changed by using ALEPHADM.

ALEPHADM lets you open, view, edit, save and print tables. The module will keep
track of all versions of a table including the information about what was changed, by
whom and when. You can make global and individual changes in the setup of the
different available libraries and databases. It gives you the possibility of preparing
reports and customizing INI files. You can use it for global changes when adapting
the system from one language to another or from one terminology to another. You can
also configure many other parameters for the various ALEPH modules, such as:

Handling of tables

Handling of libraries

Handling of INI files

Handling of languages

Handling of error messages

Configuration setup for printing, display, and so on.

1.1 Working Without a Mouse

The following table shows the default shortcut keys in the ALEPHADM GUI. These
shortcut keys can be customized.

Function Shortcut Key
Add new line Ctrl+N
Application Configuration | Ctrl+I
Check In Alt+l
Close Table Help Alt+F4
Common Dictionary Ctrl+D
Copy line Ctrl+C
Cut line Ctrl+X
Delete line Delete
Find Next F3
Find in table Alt+3
Font Configuration Ctrl+F
Insert empty line Ctrl+l
Interface Languages Ctrl+B
Language Manager Ctrl+L
Language Report Ctrl+G
Libraries Manager Ctrl+M
Line Down Ctrl+W
Line Up Ctrl+U
New Tables Editor Ctrl+E
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Function Shortcut Key
Open Ctrl+O
Paste line Ctrl+V
Print Ctrl+P
Print Configuration Ctrl+T
Profile Manager Shift+M
Report Ctrl+J
Restore Ctrl+Z
Save Ctrl+S
Select All Items Ctrl+A
Table Help Alt+P
Task Manager Alt+T
Tables Navigator Ctrl+Q
View Key Ctrl+K
View Source Ctrl+R

2 Handling of Server Tables

This chapter includes the following sections:

Tables Navigator

Display of Tables

Tables History Management
Error Tables Dictionary

In the ALEPH system, library parameter and configuration tables are housed mainly
in library sub-directories on the server. Tables that function on a higher level than
library or are shared by several libraries are in alephe and pop-up messages in
$aleph_root/error_Ing.

These table files stored on the server cannot be directly modified by a user from his
workstation. A user must load a file from the server to his PC in order to handle it.
After editing the file, he sends it back to the server in order to save changes there.
ALEPHADM is the appropriate interface for this task.

When opening a table, you must decide whether you want to save changes or just
open the table for viewing without being able to make or save changes.

2.1 Tables Navigator

Use the Tables Navigator to load from, edit and save tables. The Tables Navigator
offers you access to one table per open window. Several windows can be displayed
simultaneously. You can choose between read-only and write mode and different
display modes.

To access the Tables Navigator:

From the main menu, open by clicking the main menu at Tables> Tables Navigator
Al

B

[ icon. The Tables Navigator window opens:

(Ctrl + Q) or click the
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This window contains three work areas. Going from left-to-right, these areas are:

e Library selection
e Table selection
e Command buttons

Library Selection

In the Library selection section you choose the library and directory you want to work

on.

Table Selection

In the Table selection section you choose the table you want to work on. The list in
this section depends on the library and the directory chosen (see the ALEPHADM

System Librarian chapter on tab alephadm.lng).

Command Buttons

To update a table, follow these steps:

1. Double-click the name of the file containing the table you want to
update. You are asked if you want to check out the file in order to be
able to edit it. Click Yes to proceed to editing mode.

2. Edit the table.

3. After you have modified the table, go to the Tables Navigator and click
Check In. This sends the table back to the server and overwrites the
previous version of the table file.

Get

The Get button copies the most recent version of a file from the server to your

workstation.
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Check Out

Check Out takes a file and locks it on the server for all other users accessing the table
through ALEPHADM. The table is not locked for users who access it directly on the
server.

The lock is in force for a set amount of time. Lock info shows until the time the file is
checked out and therefore locked. Lock time is set in alephe/pc server defaults.
The variable is file lock period.

Refresh

You can extend the lock time by clicking Refresh as long as the light in the lower left
corner of the Table window is green or yellow. The time counter begins a new
countdown.

Check In

Once you have finished your editing you send the file back to the server by clicking
Check In. This saves the file and replaces the old version of the file on the server. If
you do not check in the file before the lock time runs out, the file status reverts to
read-only mode. The light in the lower left corner turns red. All changes are lost.

Edit
Edit opens the table in a separate window. Edit is active only if you have previously
used the Get or the Check Out command.

Select All
Clicking this button selects all tables from the subdirectory that you chose in the
Library selection section.

Print

Clicking the Print button prints the list of files displayed in the Tables selection
section on the Tables Navigator. If you want to print the contents of a file that was
opened in a Tables window, use the Print icon on the icon bar at the top of the
ALEPHADM window or the command File > Print.

Find
Find facilitates finding a table by a text string in the table name or the table
description. After an initial hit, the button changes to Find Next.

Find Next
Find Next lets you search for more occurrences of the same string in all columns of
the Tables Navigator.

2.1.1 Open Read-only from the Server
To open a table from the server and view it without effecting changes:

1. Highlight the table and click Get.

2. Click Edit (or double-click the table name). The system asks you if
you want to check out the file.
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3. Click No to open it in read-only mode. You can identify this mode by
the red light in the lower left-hand corner of the window.

2.1.2 Open for Editing from the Server

To open a table from the server and save changes, highlight a table and click Check
Out. Check Out takes the file and locks it on the server for other users for a fixed
period of time. Lock info shows up to what time the file is checked out and therefore
locked. Lock time is set in pc_server defaults: file lock period. As long as the
file is still checked out, it is marked with a check.

File MName | Server Time | Locked Ukl | Local Time
[ edit_field.eng 26/08/2003 ... 17:12 14/10/2004  14/10/2004 14:25
[Z] edit_paragraph.eng 03/09/2003 ...

If the file has already been checked out, clicking Edit causes the table to be opened in
the editing mode. You can identify this mode by the green light in the lower left
corner of the window. Three minutes before the lock time runs out, the green light
turns yellow. You can extend the time available by clicking Refresh as long as the
light is green or yellow. The time counter starts a new countdown.

2.1.3 Save to Server

After having checked out a table, and after you have finished your editing, you should
send the file back to the server by clicking Check In. This replaces the old version of
the file on the server. If you do not check in the file and the check out time runs out,
the file status reverts to read-only mode. The light in the lower left corner turns red.
All changes are lost.

2.1.4 Save to Workstation

The process of saving a table to your workstation is governed by the same rules as
saving to the server except that instead of using the "Check In"-function, you should
use the command File > Save. The table is stored locally under the subdirectory
containing your profile. (. .\alephadm\files\<library>\tab). A backup version is
stored in a subdirectory below this one,
(..\alephadm\files\<library>\tab\backup), if the table is loaded from the server
to the workstation for a second time or if it is saved locally. In this case, the latest
version replaces the one in the tab sub-directory which is moved to the backup sub-
directory.

2.1.5 Open Read-only from the Workstation

If you want to open a table that was saved locally and view it without effecting
changes, use the command File > New Tables Editor. An empty window is opened
and you can load a table from your workstation. Choose a table in the appropriate
subdirectory by using File > Open. In this case, you do not need to start the Tables
Navigator.

2.1.6 Open for Editing from the Workstation

If, in the Tables selection window, you double-click a table that has not been checked
out yet, you are asked if you want to check it out. If you want to edit and be able to
save afterwards, click Yes. If you only want to view it, click No.
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2.2 Display of Tables

To display a table, you must open it in a Tables Window. You can choose between
three table views:

e Table view
e Form view
e Source view

The first is a grid-only type, the second is a combination of grid and form and the
third is a plain text, notepad view.

2.2.1 Table View / Form View

Table view shows all lines of a table in a spreadsheet layout. To see a table in Table
view, go to Edit > View Tables As and choose Table.

i Defirition of G deogp-down menees (subl sensitiv [ USM500tah - pe_tab_ewp field_estended.eng )

=l B A
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BOR-STATLS FRddE L Undergraduste shident 12
EOR-STATLS Frany L Ewterson School degroe canddate 14
BOR-STATLIS FrEas L Sumemer School shuders 15
BOR-FTATLES #rean L Lite oy spcial borsower (50 50
BOR-STATLS BEEAE L Libr ary’ spacial boriosmr (S1) sl
BOR-STATLS sErRe L Irberlibrary loan &3
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Form view divides the window into two parts. On the left side of the window, the first
few columns (depending on their widths), are displayed in a grid view. On the right
side of the window, all fields are listed with their respective descriptions. The value
displayed for each field is according to the highlighted line on the left side of the
window. To see a table in Form view, go to Edit > View Tables As and choose
Form.
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You can toggle between these two view modes by clicking their respective icons.

Click for Form View.

In both these modes, there is a toolbar on the top of the window. If the table is not
checked out, or if the locked time expires, all toolbar buttons are inactive.

The toolbar buttons effect the following changes:

Adds a new line at the end of the table

Inserts a new line before the highlighted line

Deletes a highlighted line

,’._ Moves a highlighted line one line up
| + Moves a highlighted line one line down
a
=

Opens a general table help window (like F1)

0 Extends lock time when a yellow light appears (like the Refresh button)

If the file has been opened in View mode, you cannot make changes. You can identify
this mode by the red light in the lower left corner of the window. The yellow light
icon is only displayed if the light in the lower left corner of the editing window is
turning yellow.

Help and Hints for Tables:
There are three kinds of help available to explain details of an open table.
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Hint

A hint pops up when the cursor rests for several seconds on the column heading in
Table view and on the field label in Form view. The hint disappears after a few
seconds.

Column-specific Help
Right-click the column heading in table view and the field label in form view to open
the column-specific help. The Escape key closes the column-specific help window.

General Help
General help for an open table will pop up in a window when pressing F1. The Escape
key closes the general help window.

2.2.2 Source View

To view a table in plain text, open it with Edit > View Tables As and choose one of
the aforementioned options. Then use the command File/View Source. This opens the
table in a Notepad window:

& pc_tah_esp_field_sutended.eng - Hotepad M= E
Fle EdE Format Hefp
Pl 23 1 ! 5 -
T TR L e T I T T T LT UL P TR
=
BOR-5TATUS et T, Faculty 01
BOR-STATUS #HHEEE L Officer 0z
BOR-5TATLIS FHEHERE 1. Staff 03 H
BOR-53TATUS G L Graduoate student 12
BOR-STATUS iR L Undergraduate student 13
BOR-STATITS st L Extenzion School degres candidate 14
BOR-STATUS #HEEEE L Summer School student 15
BOR-5TATUS s 1, Library special borrower (50) 50
=i

2.3 Tables History Management

Monitoring and tracking changes is facilitated by using the History and Diff Log
functionalities.

To use the History and Diff Log functions, you must activate the History option. This
is done from the main menu by clicking Tables/Activate History. This has to be
done before effecting changes in tables so that ALEPH can keep track of them.

2.3.1 Tables History

The Show History command lets you access older versions of tables. You can use the
From/To Date and/or the User filters to limit the range of versions you want to
display. If you want unlimited range, that is, all versions of a table, click OK. You
can see a list of all older versions of a table showing user names and time-stamps:
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[l History of $\USM50\tab\tab30
History: 4 Itemls)
Liser I Date
* cire 22/06/2003 16:53:00
* ire 22/06/2003 16:52:40
+ dept 22[06{2003 16:50:13
" dept 22/06{2003 16:49:31
Wiew
Sheowy [if
Help
J | ]
This Ale was sawved in:
OwEN0_16\alephadm files\LSME0 Ak History it ab30, dept 20030622, 165013,

Report
The Report button allows you to decide where your report should be sent (printer, file
or clipboard).

Purge
The Purge button lets you purge any number of older file versions on the server.

Get
The Get button loads the highlighted version of the file from the server to client.

Restore
The Restore button replaces the current version of the table with the highlighted
version. The replaced version will then appear in the history window.

View
The View button opens the highlighted table in a new window.

Show Dif
The Show Dif button shows you the differences between the current and the
highlighted versions:
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2.4 Tables Log

Show Log shows you the User name, IP address and time-stamp of every Check In
action.

Eil Log of $\USM50\tab\tab30 [_[O]
Log: 4 Itemis) e
User | 1p | Date | e
CIRC 010,001.235,156 Z2/06{2003 16:53:00
CIRC 010,001.235,156 22/06/2003 16:52:40 Clear
DEPT 010.001.235.156 22{06/2003 16:50:13
DEPT 010.001.235.156 22/06/2003 16:49:31 Halp
Close

The Close button closes the Log window.

Report
The Report button allows you to decide where your report should be sent (printer, file
or clipboard). You can choose between Printer, File and Clipboard.
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Clear

The Clear button lets you clear items from the Log list. You can choose how many

items you want to delete.

2.5 Error Tables Dictionary

This function is part of ALEPHADM language handling. Contrary to the other

language handling functions which influence the client only, the Error Tables
Dictionary function affects server tables.

The Error Tables Dictionary shows you all error messages from all modules together
and lets you edit them. It also shows the filename where the message is written for

each error message.
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Zl pe_cem_oiH oz

The error files are in the server's $aleph root/error 1ng directory. They can be
accessed one by one in individual windows by using the Tables Navigator.
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Tl

|
:

i
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=] ﬂ::%“:ﬂlﬁ muumc [Fietiane [ServeTme | %oe| Lockedud Local Tine -
- = i I TRAIA00 4. 230
il USHTY - USMARC Authorite2) g :::x_:msa 16172000 14, SEw
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j f:;'w“”" (B) pee_eewn_e0141 TEM2000 14, S0
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If you have checked out a file and thereby locked it, you see this icon @ next to the
filename.

If another user has checked out this same file and thereby locked it, you will see this

icon I@ next to the filename.

3 Handling of Client Tables

Every ALEPH client has a set of subdirectories with tables containing various
definitions. Client tables from the files and tab subdirectories are accessible through
the ALEPHADM module. They can be recognized by their .dat or .ini extensions.
These tables are used to set different parameters pertaining to the client and can be
adapted by each user when configuring his workstation.

3.1 Handling of Libraries

The Libraries Manager lets you handle the list of libraries that can be used in the
client. It also lets you determine and view which libraries each ALEPH client module
uses. You access it through the menu Configuration / Libraries Manager. Four tabs
display the current permitted libraries, a list of all available libraries, Bases for Locate
and Bases for Search.

Note

In order to be able to handle libraries, you have to use the "default" profile when
opening the ALEPHADM module.

ProfileControl

Please enter your profile:

I def ault

(04 I Zancel

3.1.1 Permitted Libraries

"Permitted Libraries for Client" defines which libraries can be accessed from each
module. You can add or remove a library by double-clicking the appropriate cell:
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| Libt aries

I Eazes for Locats

I Eazes For Search I

m Libraries Manager E3

Permitted Libraries

alephadm

|acq

|cata|cng

|circ [l

PCWER

ALEPH
Usmol
Usmi0

UM

LUsml 2

USh1 4

Usm15

UsmMz0

LUsm21

UamMzz

LUSm30
UsmS0
LUSMS1
USman

USME1

LUsSRO0

LSS0

=

il

-~

| Il

LCancel | oy, |

Help

3.1.2 Libraries

"Libraries” defines the location and PC server port for all the libraries that are
accessible through the client. You can change an entry for one library and apply it to
selected libraries or to all of them. You can add or delete a library or move it up or

down by using the toolbar. The permitted libraries are listed in the order shown here:

Parmitted Libraries

Libraries

| Eazes for Locats

I Eazes For Search I

Bl Libraries Manager E3

Keys:
— Description:

Library Eo...| Fart | D ezcription

|PCVER

ALEPH
LISMO1 10.1.235.19:6991 | USMO1 - USMARC Bibliographic
LSH10 101235196991 | USH10 - USMART Authority
USH11 10.1.235.19:6991 | USM11 - USMARC Authority(2) _ _
LISM12 10.1.235.19.6991  USM12 - MESH Authority Host Name: Pt
LISh14 10.1.23519:6991  USH14 - USMARC Thesaurus [T01.23513 . [e3m
LISH15 101235196991 | USM15 - USMARE Subjects
LISM20 10.1.235.19:6991 | USM20 - USMARC ILL ™ Apply ko Al
LSM21 10.1.235.19:6991 | USM21 - ILL Server Librarny
LISH22 101235 19:6991  USM22 - Loaders Library I ol to All Selected |
LISM20 10.1.235.19:6991 | USM30 - USMARC Course Reading apl ol Selacizg o
LISMED 10.1.235.19:6991 | USME0 - USMARE Administrative
LISH51 10.1.23519:6991 | USMS1 - USMS1 —
LISMED 10.1.23519:6391 | USMED - USMARC HOL records
LISMET 10.1.235.19:6991 | USMET - USMART HOL records(2]
USRO0 10.1.236.19:6991 | USRO0 - Admin
LISH30 101235196391 LUSMS0 - USM30
EXTO 101.235.19:6991 | Z39 - MARCZ] Z39.50 =
5TTI'I'7 1M1 79 19-F991 FA9 L IMIKART A9 BN ILI—I

LCancel oy,

Help
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3.1.3 Bases for Locate

The "Locate" function is available in the Cataloging and Circulation modules. It is
used to find matching records in remote databases. The choice of databases is taken
from the list displayed in "Bases for Locate". Each base listed must also be listed in
the server's tab base.<1ng> table. The information displayed in Bases for Locate is
stored in ALEPHCOM\tab\locate.dat!

Libranies Manager
Perrnitted Libraries I Libraries Bazes for Locate | Bazes for Search I
keps: -
- — — Description:

Baze for Locate | Library Code | Drezcription

S0 i LIS {UsMO1
SKM10 USKM10 ISM10
Sk 11 Sk 11 15011
sma0 S5m0 1520
LoC EXTO Library of Congress — Library Code:

USMDT |
1] |2
oK I LCancel | Eppl | Help |

3.1.4 Bases for Search

The list of bases for the GUI search determines which Bases are offered in the Search
module when you use the Connect to menu option. The setup of this list can also be
updated through the Search module from the Main Menu in Search using Options >
Database. Each base must also be listed in the server's tab base.<1ng> table. The
information displayed in Bases for Search is stored in sear\tab\base.dat:
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Libraries Manager

Permitted Libraries | Libraries | Bases For Locate E:i{ﬁﬁ'ﬁﬁf:ﬁﬁi}f{::'.:'_:"E]
Foeyps: Descikii
BaseforSearch | Libray Code | Dresciiption FEE
LISk400 (E1 5 ) LISKMO |USMEI1
EDLCS sk Education
WD 5O B ain Libr apy
HIL LISMO Husnanities Library
HYL UsMO East Azian Librany  Libraies:
L 1R 1| Main Undergraduate Lib.
MED UsmMO Medicine Libray Sk j
Lahf EmMm Laws Schoal Librany
MU LSk Busic Lioeary
LIT sk Economics Library
LSk410 U510 LISM10
LISk 51 LISM11
LISkZ0 USKz0 UsM20
LoC ExTM Library of Congress
O=FORD EXTN O=fard (23950
SUNTA EXT SUNY Albany [£33.50]
PICA_GGC ExTOM FICA Catalog [£39.50)
LINIDT LINIO UMIMARC Bibliographic
LMIT0 UNITD UIMIMAR C Awthonbes
4] |+
feT3 I LCancel I Helo

3.2 Handling of ini Files

3.2.1 Application Configuration

The Application Configuration shows you the standard values and the actual setup of
INI files for each module.

! Application Configuration

Appdicationg:

ALEFHA0M
Fuguiskions[Sarials
Cataiogrg
Cirgulatlon
Inteshbrary Loan ;l

Current Paths CiWSD0_ 1602 alephroon) Tab'\alepheomuini

Current Text Ex Libeis Standard

[LLERLT]

Dagnostcsy
L]

Bibinfof ormat=333

ACTivRLeES Pl as Ao =R
ApplicationBgColar=190,240.215

Targets=printer] printer02, phaotoslip, phatawait, photafi

Surmmand@iblnfef ormats-1

= e

'anm
o[

The following INI files are viewed and edited in the Application Configuration.

acg.ini

circ.ini

catalog.

alephcom.ini
alephadm.ini

ini

To edit a field, place the cursor on it and double-click. Lines with a field whose value
was changed are highlighted in gray. The original is always retained in the right-hand
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column. Clicking the "Default value" button brings back the original value of the
highlighted line.

3.2.2 Print Configuration

In the Print Configuration, you determine the print settings for each module
separately. To edit a field, place the cursor on it and double-click. Lines with a field
whose value has been changed are highlighted in gray:

il"lll‘lt Conhiguration

Applicsbors: Currecd Patha SOALS00T~ 1icine\TabiPrird ni
Funciion Mame |!I:I |5r:tup |Mii| lLucaIl’iltNamt|Ttrgttl |Tarqtt2 ﬂ e I
LoanFeceipt oo M P loanreptprn DEVICE-04

Pt s i) P photowE B n _l
Photoblip o M F photosp. prn -
il | k]

Irferlbeary Loan

Ex Libriz Standard:
Funciion Mare |1D |5:tup |Ma|| EanaH‘iltthuge:I |Tarqtt2 -
LoanFeceipt 00w P panreptprn  DEVICE-04
Photowaie oo M P phottwE prn Cancel
Frotoslip 0o M ] 5 |

photos|p.prn -
<1 o e |

3.2.3 Font Configuration

The Font configuration options show you the file \alephcom\tab\font.ini in a table-
view editing window:

[ Font Configuration [_ O}
1. Entr | 2. From Unicade value | 3. To Unicade walue | 4, Facename of Font | 5. Bold | 6, Italic | 7.Un &
EditorTag Qo000 OFFFF Courier b V] V]
EditorField 0a0aa Oao0FF Tahoma i M M
EditorField 003554 O03CE Tahoma b M M
EditorField no401 0045k Tahoma i M M
EditorField nosoco O0SEA Tahoma b M M
EditorField Qoo OFFFF Arial Unicade M3 ki M M
EditorDescription 0o0og Q00FF Tahoma i i M
EditorDescription 00401 O045F Tahoma i I I
EditorDescription 00354 003cE Tahoma i M M
EditorDescription 00s0o QO0SEA Tahoma i I I
EditorDescription 00000 OFFFF Bitstream Cyberhit W ¥ N =
ListBoxCaption Qo000 QO00FF Tahoma M M M
ListBoxCapkion 00401 0o045F Tahaoma ] V] V]
ListBoxCaption 00354 003CE Tahoma M M M
ListBaoxCapkion 0os0o O0SEA Tahama ] M M
ListBo=Caption 0oooa OFFFF Eitstream Cyberbit M M M
ListBoxd# Qoo O0oFF Tahoma M M M
ListBox## o401 o045k Tahoma M M M
;ListBoxa# 0035 003 Tahoma
ListBox## aosoo O0SEA Tahoma M M M
ListBox## Qoo OFFFF Arial Unicode M3 b M M
UnicadeEdit 00000 Q00FF Tahoma M M M
UnlicodeEdit 00401 0045F Tahoma | M il il hd |
A »

@

Although this looks like a checked out server table, it is not. You can effect changes
and save the file with the command File / Save.

3.2.4 Report

After the client installation is updated from the source, the Report shows the
differences between the current and previous Application.INT and/or print.INT.

The files that are actually compared are:
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X:\AL500 16\module\tab\module.ini and
X:\AL500 l6\module.sav\tab\module.ini

If there were no changes the Report remains empty.

3.2.5 Profile Manager

In a network installation, the Profile Manager lets you define users and their profile
paths. You can add, delete and modify each entry. In order to be able to activate the
Profile Manager before profiles have been defined, you have to access the system
with the "default™ profile:

ProfileControl E3
Please enter yvour profile:
| defaui

Ok I Cancel |

3.2.6 E-Mail Settings

The E-Mail Settings and Options dialog box can be used to configure the following
e-mail parameters:

e Mail Server address and port.

e Authentication method — The supported methods are PLAIN and LOGIN.

e User Name and Password — The user name and password that are to be used if
an authentication method is defined.

e Secure Connection — The supported methods are TLS and SSL.

i »
E-Mail Settings and Options S|
Mail Server : Port | IL-EXDL ] | 5 | oK |

Authentication Options

Authentication Type |LoGn |
Username | taryag
Password | ”””

Secure Connection

(" Mormal
(" TLS
Cancel |
{* S5l
Help |
b
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3.3 Handling of Languages

The ALEPHADM client is used to configure settings for appearance and functionality

for the various ALEPH client modules.

3.3.1 Interface Languages

Setting the Interface Language

The Conversation Languages command lets you set the interface languages that are
available in Aleph. You can add, modify or delete a language or set any language as

the default:

Current Languages:

Add

ENG L English
|GER L German

Madify

x|

Delete

Default Language I

Language Code: | HEB

Direction: (" LefttoRight  (* Right to Left

Update HEB

Directary:in &l
spplications from

Origiryal Text

Description: l Hebrew

Close

Help |

Current Languages:

Add

Hebrew

Modify

Delete

Language Code: | GER

Direction: {* LefttoRight ( Right to Left

Update GER

Directary:in &l
Epplications from

Oriairyal Text

Description: l German

Close

Help |

Staff User’s Guide — Aleph ADM
January 13, 2014

21



Update Interface Languages

Current Languages:

Hebrew

Madify

Delete

x|
|
|
I

Default Language I

Language Code: GER

Direction: {¢ LefttoRight ( Right to Left

Description: I German

Update GER
Directory in all

Applications from
Original Text

(e
S

Cancel

Help I

When choosing the ‘Update GER Directory in All Applications from Original Text’

option, the German files are synchronized with xxx_ger master directories. All other

languages are synchronized with xxx master directories.

Retaining Customized Text When Updating

When you update from an older to a newer version of ALEPH, you may want to keep
those parts of your text that you customized. Old lines (shown without hashes) in

tables are retained and new lines are added (in English, as default):

3.3.2 Language Manager

The Language Manager lets you choose the module and the language files that you
want to work with. You can also change all text entries in each of the modules

according to the language you choose:

—Selact Application to Edit:

E‘ Language Manager E1

Maodule Description I O I

hoom  Cammon headin 35
slephadrm  AlephaDin

acg Acquisition
catalog Cakaloging
cire Circiilation

ill Inkerlibrary Loan

Select Larsguage bo Edit: Cancel

Englich :|

|
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The Language Manager shows you which module, which language, and which part of
the text you are working on. You always see the original and the new text:

E alephcom [English] | (O] x|

Ponth ] StatusEar ] Tab_cal I nrindowe ]
Errer [ Hind ] Mg I Massage ]

Jumpto: | find.. | e |

Service | MoEror | Mew/Defauk [~

GLOBAL
GLOBAL

[ R

Mew Caption:

2
3
4
GLOBAL 5
6
i
8

A i B

-

[I:-:nmnmnicatil:nn eror
Original Capticr
[I:-:nmrmnicatim Eror

Mew Message:
[Wru:ung WETZION

Original Meassage:
['+rong version.

chope Hilp | Cancel |

Modifying
Changes in each line of the text are retained by clicking Modify.

Saving
After making changes in the text and clicking Modify, you can save all changes by
clicking Save.

Restoring
If you want to undo your saved changes, you can go back to the situation before
saving by clicking Restore.

If you want to use new terminology for a specific expression, you can change the
terms globally using the Language Manager.

3.3.3 Language Report

After the client installation is updated from source, the Language Report shows the
differences between the current and previous version's Ex Libris standard. Changes
that were made with the Language Manager are not included in the Language Report.

e error.dat
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e hint.dat

e menu.dat

e message.dat
e month.dat

e statusbr.dat
e tab col.dat
e window.dat

They can be found in: \<module>\Tab\xxx\*.dat and \<module.sav>\Tab\xxx

\*.dat.
Language R opodt | - [O] =] I
Appe stioess: Erordst | Hobdet | Menudst | Messsgeds | Meethdw | o]0
Ky | Mg Toet Qld Teat - Eyint I
GLOBAL <97 Remobs Fie Emor  Ervor sendin..,
GUOBAL <96  Cff-Line cataloging The operati.,
GLOBAL -95  Reswobe Fie Eror  Unasbls o .,
Al Applcstians GLOBAL -94 Pemobs Fiie Eror  Pernate fle ..
GLOBAL <93 Rescbs Fils Ermor Urasbls to o,
GLOBAL -97  Remobe Fiie Eror  Unabla oo,
GLOBAL <91  Reswobs Fie Eirer  Unabls o o.,,
GLOEAL -80  Remobe Flie Eror Bocess dend.,
GUOBAL <33 Commmuracation error Incompali. ..
GOBAL -22  Commuracation erroe Liser braak -
GLOBAL <11 Commuracation erroe Library's ...
GQORAL -3 Commuracation ermor ALEPH g0...
GLOBAL -7 Commurecaton error Fadedior,., Clos |
GUOBAL -6 Commurication error Faded bo ., -
« I rl‘l mEe

You can view and print text for each module separately or for all the modules
together. If there were no changes, the Report remains empty.

3.3.4 Common Dictionary

The Common Dictionary displays all text strings of all modules in alphabetical order.
There is one Common Dictionary per language. You can look for any letter string.
You can change all entries and save your changes. The Common Dictionary also
shows you the filenames with their paths where the text string is to be found.
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E'I omrnon ictionary | Eniglish )

Ede  Language Help

g ba: | Lindo|

Zalected lbem: 2100

umbser of Ibemer 3242

Lirisbde fo find prinkoot parsmet ers,

Lirbie: to g bo podition: il nin %
Liruabie B ok e Fle s,

Lirusies B [acabe buthon: Yhdininen s
Uinable o locate conbral: Shadinlnin %

Lirushiles to lacats poskion dol; Sedininm %
Lirushie b opesn local File,

Unabée o opon printout flo: %
Linaabie o opon tenporany fle for printout le: s
Liruskiles 1 oo Vo b rebmtis .

Liruable b perames cinactory s,

Uirable bo replace Rl s with iocal wersion Ss,
Unable to resobee hast address.

Urusbée to pun Sawon.

Liriabie bo uncompe g5 local fils

Lirusbie ti wribe 1o bocal ke

Linabis o dedabe patnon because cash balance 5 not ;ero \ninClea,..
Lirusliies ta cisbabe sty ok by st sk iy nipDusbabe Uit 5,
Unabls to delabs user because cash balance i rok pero, \nialear ¢,
Unable bo delebs wuser because of sttadhed loare\ ELL requests. nin...
Uinabie: to dedebe wser because the wser i & routing list group leade...

Linabie to dalete patron becase cach balance s not 2ero ipincle,. .
Ll 1y diabsli fuskrin dhos R altac s kaane|nlnDesbeto i o,
Linabls io delebs user became cash balanes & fok zevo, {nlallesr, ..
Unable bo delebe user Becauss of attadhed loars U ILL requests.\nd...
Unabie to delebe user because the user & & routing st group kead.. .
Uirisbles b find pringoot paramet ers,

Unable 1o go bo pesition: dininin s

Uikl Lo brpel the Fle %,

L s lazite button: Yhdin) nin %s

Uinable 1o locake combral; Shadinlnin e

Uinabls 1o lacsts poskion sl “edininm %S

Lirusbles to opesn bocal File,

Unabie to open prntout flo: %

Uinabie to opon temporary flo for prncout fle: s

Lk 1oy oo abe rasmctin i,

Linabda b reniaine disclory S,

Uinable bo replisce bl s with local wersion Ss,
Unable to resolee host address.

Unabie 1o pun Samon.

Uinabls 1o uncompress locsl fils.

Liewsble 10w Lo bocal File

BUn&cr s Bt ik
Liraes s Lirderlrs
Bl B =
VSO0 _L&. 02 akakogh Tab ENGYMnu. dat Ui

Suve B

[0

%

e To save your changes, click Save To Files.

e To undo the last save, click Restore to go back to the former version

of the text.

e To save the New Text column to a *.TXT file, click Save As. The
default path and filename is Alephadm\Bin\CommonDictionary. TXT.

e To send the list to a printer, click Print.

e To search for a letter string in the New Text column, click Find. After
you find the first match, Find Next... becomes active.
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