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Polaris Installation Notes

Important:
When the new Polaris release is installed on a workstation, the file path
changes from 7.4 to 7.5 as in the following examples:

C:\ProgramData\Polaris\7.5
C:\Program Files\Polaris\7.5
C:\Program Files (x86)\Polaris\7.5

© 2024 Innovative (Part of Clarivate)
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New or Modified Polaris Administrative
Settings
The system administration settings below have been added or modified to support the
new features in Polaris 7.5.

Setting Purpose Level

New Parameters

Patron Services >
Check-out: Increase
Total Item Limit

Defines the number of items a patron can
check out in addition to the total item limit
defined in the Patron/Material Type Loan
Limit Blocks policy table as part of the
increased check-out limits feature. For
details, see Increasing Check-out Limits by
Branch.

Branch

Request > Holds
Options > Pickup
Area

Allows you to:

l enable pickup area to appear system-
wide

l select the default pickup area

l enable pickup area to appear in PAC

For details, see Using Pickup Areas.

System, Branch

Patron Services >
Overdues: Charge
fines for dates
closed

Specifies whether Polaris charges overdue
fines on closed dates. The default setting
is No. For details, see Charging Overdue
Fines on Library Closed Dates.

System

New Permissions

Fines: Approve
waiver requests for
user threshold

Approve waiver requests for patrons in
Leap up to the maximum amount allowed
in the staff member's profile. Applies to
Leap only. For details, see Using the New

System
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Setting Purpose Level

Waiver Workflow.

Fines: Decline
waiver requests

Decline waiver requests for patrons in
Leap. Applies to Leap only. For details, see
Using the New Waiver Workflow.

System

Fines: Submit waiver
requests

Submit waiver requests for patrons in
Leap. Applies to Leap only. For details, see
Using the New Waiver Workflow.

System

Modify increased
check-out limits

Add, modify, and delete entries in the
Increased Check-out Limits policy table,
which defines the number of increased
check-outs a patron can have from specific
material types. For details, see Increasing
Check-out Limits by Branch.

System

Override age
restrictions

Continue a checkout or placing a hold
request for a patron who is blocked due to
age restrictions for a specific material type.
For details, see Using Age-Related Loan
Policies.

System

Patron Privileges:
Modify

For managers, this permission causes the
Extended Loan Period and Increased
Check Out Limit checkboxes on the patron
record to display as editable, rather than
read-only. No overrides allowed. For
details, see Increasing Check-out Limits by
Branch.

System

Weeding templates:
Access, Create,
Delete, Modify

For staff that manage weeding templates,
these permissions allow a staff member to
access, create, modify, and delete weeding
templates for their logged-in branch. For
details, see Using Leap's Improved
Weeding Workflow.

Branch
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Setting Purpose Level

Weeding: Approve For reviewers and approvers to move the
weeding record set along in the approval
process. Approval can change the status of
a weeding record set from In Review to
Approval Requested or from Approval
Requested to Approved. Applies to Leap
only. For details, see Using Leap's
Improved Weeding Workflow.

Branch

Weeding: Decline For reviewers and approvers to move the
weeding record set back to Pending in the
approval process. Applies to Leap only. For
details, see Using Leap's Improved
Weeding Workflow.

Branch

Weeding: Submit for
approval

For staff to submit weeding record sets for
review or approval. Applies to Leap only.
For details, see Using Leap's Improved
Weeding Workflow.

Branch

New Profiles

Staff Client >
Automated object
lock clearing: Age of
lock to clear

Specifies which object lock entries the
Clear Object Locks SQL job removes from
the Object Locks database table. For
details, see Configuring Polaris to
Automatically Clear Object Locks.

System

Staff Client > Web
App: Custom 1 URL

Specifies the URL that corresponds to the
Web App: Suppress Link: Custom 1 setting.
When a user selects the Custom 1 menu
option, Leap opens the website you specify
here. For details, see New Custom Menu
Options in Leap.

System, Library,
Branch

Staff Client > Web
App: Custom 2 URL

Specifies the URL that corresponds to the
Web App: Suppress Link: Custom 2 setting.
When a user selects the Custom 2 menu

System, Library,
Branch
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Setting Purpose Level

option, Leap opens the website you specify
here. For details, see New Custom Menu
Options in Leap.

Staff Client > Web
App: Library
Documentation URL

Specifies the URL that corresponds to the
Web App: Suppress Link: Library
Documentation setting. When a user
selects the Library Documentation menu
option, Leap opens the website you specify
here. For details, see New Custom Menu
Options in Leap.

System, Library,
Branch

Staff Client > Web
App: Suppress Field:
Extended Loan
Periods

Indicates whether the Extended Loan
Periods checkbox is suppressed from
display in the Leap Patron Registration
workform. Applies to Leap only. For details,
see Managing Extended Loan Periods.

System

Staff Client > Web
App: Suppress Field:
Increased Check-out
Limits

Determines whether the Increased Check
Out Limits checkbox appears on the Leap
Patron Registration workform. This
checkbox enables the increased check-out
limits feature for a patron. Applies to Leap
only. For details, see Increasing Check-out
Limits by Branch.

System

Staff Client > Web
App: Suppress Link:
Custom 1

Determines whether the Custom 1 option
appears in the Utilities menu in Leap. When
a user selects the Custom 1 menu option,
Leap opens the website specified in the
Web App: Custom 1 URL setting. For
details, see New Custom Menu Options in
Leap.

System, Library,
Branch

Staff Client > Web
App: Suppress Link:
Custom 2

Determines whether the Custom 2 option
appears in the Utilities menu in Leap. When
a user selects the Custom 2 menu option,
Leap opens the website specified in the

System, Library,
Branch
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Setting Purpose Level

Web App: Custom 2 URL setting. For
details, see New Custom Menu Options in
Leap.

Staff Client > Web
App: Suppress Link:
Library
Documentation

Determines whether the Library
Documentation option appears in the Help
menu in Leap. When a user selects the
Library Documentation menu option, Leap
opens the website specified in the Web
App: Library Documentation URL setting.
For details, see New Custom Menu Options
in Leap.

System, Library,
Branch

Staff Client > Web
App: Use waiver
request action

Determines whether Leap replaces the
current Waive action on the patron account
with a Waiver Request form. Applies to
Leap only. For details, see Using the New
Waiver Workflow.

System

New Policy Table

Hold Pickup Areas Defines the pickup areas within a pickup
location that staff members and patrons
can select when placing a hold request. For
details, see Using Pickup Areas.

System

Increased Check-out
Limits

Defines the number of additional items that
a patron can check out from specific
material types as part of the increased
check-out limits feature. For details, see
Increasing Check-out Limits by Branch.

Branch

User Defined Waiver
Request Reasons

Defines the reasons staff can request a
waiver for a patron. For details, see Using
the New Waiver Workflow.

System

Modified Database Tables

Transaction Logging You can now configure Polaris to log System, Library,
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Setting Purpose Level

transactions when staff-generated blocks
are added to or removed from patron
records. The Transaction Logging
database table now contains the new
Patron block added and Patron block
removed transaction types. For details, see
Logging Transactions for Patron Blocks.

Branch

Modified Permissions

Cataloging record
sets: Access,
Create, Delete,
Modify

Cataloging record set permissions are
modified to include weeding record sets.
Applies to Leap only. For details, see Using
Leap's Improved Weeding Workflow.

System

Modify
lost/damaged item
amount

This permission now also applies to fees
for damaged items. With this permission,
you can change the amount of the
replacement charge or processing fee
when declaring an item lost or damaged.
For details, see Declaring Items Damaged
in Leap.

System

Special item check
in

This permission now also applies to
checking in damaged items. With this
permission, you can check in damaged
items in Leap. For details, see Declaring
Items Damaged in Leap.

System, Library,
Branch

Modified Policy Tables

Material Types Names the various material types held by
the library. Minimum Age column added to
support age-related loan policies. For
details, see Using Age-Related Loan
Policies.

System
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Setting Purpose Level

Modified Profiles

Patron Services
> Waiver approval
threshold

Works with the Fines: Approve waiver
requests for user threshold permission to
set the maximum waiver amount this staff
member can approve. Applies to Leap only.
For details, see Using the New Waiver
Workflow.

Staff Member
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Polaris API Changes
The following methods have been added or updated:

Method Name Purpose

HoldRequestCreate Now returns a StatusValue of "10" when the
patron is blocked from placing a hold because
they do not meet the minimum age requirement
for that item.
Now returns an XML Body Element of
"HoldPickupAreaID" for the area in the branch
where patron would like to pick up item.

ItemCheckoutPost Now returns the following ItemBlockFlags:

l 16777216 - when the patron is blocked
from checking out an item because they do
not meet the minimum age requirement.

l 33554432 - when the patron is blocked
from checking out an item because the
item has a status of Damaged.

MultiPartGet Now returns the following for the XML Element
of Type:

l 2 - Volume (multipart set)

l 3 - Item

PickupAreasGet This endpoint returns a list of valid pickup areas
for the branch based on the organization ID.

For more information, see the topic for the method in the PAPI documentation.
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Using Pickup Areas
You can now define a pickup area within a pickup location for staff members or patrons
to use when selecting a location for picking up holds.

This topic covers the following:

1. Setting Up Pickup Areas in Polaris Administration (staff client).

2. Using Pickup Areas in Leap.

3. Using Pickup Areas in PAC.

4. Emailing and Printing Pickup Areas.

Setting Up Pickup Areas

To set up Leap and PAC to use pickup areas, you must do the following:

1. Add your library's pickup areas to the Hold Pickup Areas policy table.

2. Enable Pickup Area at the system level.

3. Designate the default pickup area and display in PAC at the branch level.

Adding Pickup Areas to the Policy Table
The Hold Pickup Areas policy table is empty by default. You can add pickup areas at the
system level or the branch level for all branches, then you can change the settings for
pickup areas at the branch level.

To add pickup areas at the system level for all branches in Polaris Administration
(staff client)

1. Open Administration > Explorer.

2. Select Policy Tables > Hold Pickup Areas.

The Hold Pickup Areas pane appears.
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3. Select Insert .

The Add Hold Pickup Areas dialog opens.

4. Enter the following:

a. Description — Enter the name to show in the pickup area dropdown lists in
Leap and PAC.

b. Sequence — Enter a number to define the display order of the added pickup
area in the dropdown lists for Leap and PAC.

c. Selected — Select Yes if the pickup area is valid for your branch, and you
want this pickup area to appear in dropdown lists for Pickup Area in Leap
and in PAC.

5. Select OK.

The new pickup area row appears in the Hold Pickup Areas pane.

You can also change or delete existing Pickup Area entries using the icons at the top of
the Hold Pickup Areas pane. For more information, search "Working with Tables" in the
Polaris staff client help.
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Enabling Pickup Area at the System Level
You must enable Pickup Area at the system level before you can designate the default
pickup area, which is the area that shows in the dropdown list for Leap and PAC by
default.

To enable Pickup Area at the system level for all branches in Polaris Administration
(staff client)

1. Open Administration > Explorer.

2. Select System > Parameters > Request > Holds Options.

3. Select Pickup Area.

4. Select Enable pickup area (system only).

5. (Optional) To display a pickup area by default in Leap and PAC, select an option
from the Default pickup area list.

This default applies to all branches until it's reset at the branch level.
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6. (Optional) To display Pickup Area options in PAC, select Enable pickup area in
PAC.

This selection applies to all branches until it's reset at the branch level.

7. Select OK.

The system displays the new pickup area fields as described in the Email and Print
Pickup Areas section.

Designating the Default Pickup Area and Display in
PAC at the Branch Level
After you add and enable Pickup Areas at the system level, you have the flexibility to set
the default pickup area and display in PAC options differently for each branch.

To set pickup-area options at the branch level in Polaris Administration (staff client)

1. Open Administration > Explorer.

2. From the branch list, select the branch name.

3. Select Parameters > Request > Holds Options.

4. Select Pickup Area.
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5. To display a pickup area by default in Leap and PAC, select an option from the
Default pickup area list.

6. To display Pickup Area options in PAC, select Enable pickup area in PAC.

7. Select OK.

Leap and PAC display the pickup area list with the default option first.

Using Pickup Areas in Leap

When placing a hold in Leap or in PAC, staff members and patrons can now select a
pickup area within a pickup location. For example, when you select a pickup location, it
is a library branch. If the branch offers multiple Pickup Areas—such as smart lockers,
curbside, and holds counter—you can now select one of those as well.

To select a pickup area in Leap

1. Go to the patron record workform.

2. Select Holds/Held.



What's New in Polaris and Leap 7.5

© 2024 Innovative (Part of Clarivate)
Page 15

3. Select New Hold.

The following image shows that the new hold area now includes Pickup Area.

4. Use the Find Tool to retrieve an item to place on hold.

5. Select a branch from the Pickup Branch dropdown list.

6. (Optional) Select a pickup area from the Pickup Area list.

7. Select PLACE HOLD.

The pickup area appears beside Pickup Branch in the holds table.
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The pickup area appears in all views of the Picklist workform.
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The pickup area also appears in the following locations:

l ILL request view in the patron workform

l ILL workform

l Unclaimed ILL Picklist

Using Pickup Areas in PAC

To select a pickup area in PowerPAC

1. Browse or search for an item to place a hold on.

2. Select PLACE REQUEST.

3. Select a Pickup Location and a Pickup Area.
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4. Select Submit Request.

A list of your hold requests appears. The pickup area appears in the Pickup Library
column beside the pickup location.
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To change the pickup area

1. To see a list of your hold requests, selectMy Account > Requests.

2. Select a hold request.

3. Select Change Pickup Location.

The Change Hold Request page appears.

4. Select the Pickup Location you had before.

5. Select a New Pickup Area.
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6. Select Submit.

A Pickup location was changed message appears.

7. Select OK.

The new pickup area appears beside Pickup Location in your hold requests list.

The pickup area also appears in the following locations:
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l ILL request form in PAC

l Hold Requests create and view in MPAC

l Requests in PAPI

For more information, search "PickupAreasGet" in the Polaris API Guide.

Emailing and Printing Pickup Areas

The pickup area can appear in the following:

l hold call slips

l hold slip

l hold pickup slips

l first and second default email hold notices

l SIP extension at check in

See the table below for steps to display Pickup Area in these places.

To display Pickup Area here Do this

Hold call slips (pickup area appears
under the location pickup branch)

Enable Pickup Area at the system level.

First and second default email hold
notices (pickup area appears after
the held-till value)

Enable Pickup Area at the system level.

SIP extension - "PA
[PickupAreaDescription]" (pickup
area appears in the message
returned at check in)

Enable Pickup Area at the system level.

Note:
This SIP extension only appears if the
checked-in item fills a patron hold and the
other hold-related fields are populated.
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To display Pickup Area here Do this

Hold pickup slips (pickup area
appears under the location for
pickup branch)

1. Enable Pickup Area at the system
level.

2. Go to Administration > Explorer >
System.

3. Select Parameters > Patron Services
> Hold pickup slip options:.

4. Select Contents Selection.

5. Add Pickup area from Options to
Selections.

6. Select Save.

Hold slip (pickup area appears under
the location for pickup branch)

1. Enable Pickup Area at the system
level.

2. Go to Administration > Explorer >
System.

3. Select Parameters > Patron Services
> Hold Slip Options.

4. Add Pickup area from Options to
Selections.

5. Select Save.

Printing the Pickup Area in Hold Notices
When you enable Pickup Area at the system level, printed hold notices display a
customizable language string. This language string advises patrons to call the library or
log in to PAC to see their pickup area.

To modify or translate the language string, update the following Notices string identifier
in the Web Admin (Language Editor) Tool: NT_HOLD_PICKUPAREA_INSTRUCTIONS.

The string appears in the following types of printed hold notices:
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l Hold Requests Full Page Mailer

l Hold Requests Half Page Mailer

l Hold Requests Full Page Mailer Dot Matrix

l Hold Requests Postcard

l Hold Requests Z Fold Mailer

l Hold Requests Z Fold Mailer Oversized
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Using Age-Related Loan Policies
Using age-related loan policies, you can now configure Polaris to restrict check-outs and
hold requests for specific material types based on the patron's age. For example, you
can block patrons under the age of 13 from checking out or placing a hold request on
movies rated PG-13. These blocks apply to the initial check-out only; Polaris does not
check the patron's age during renewal transactions.

Once set up, age-related loan policies work wherever you can place a hold request or
check out an item, including Leap, Polaris staff client, ExpressCheck, PAC, and Polaris
API.

This section covers the following topics:

l How Age-Related Loan Policies Work

l Setting Up Age-Related Loan Policies

How Age-Related Loan Policies Work

When library staff or patrons check out an item or place a hold, Polaris performs a
minimum age check as follows:

l Identifies the material type associated with the item and determines whether a
minimum age is set in the Material Types policy table.

l If a minimum age exists for the material type, compares it against the birth date
field in the patron record.

If the patron is younger than the age specified for that material type, the system displays
a Minimum Age alert. For example, this is the alert that appears in Leap:
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Library staff who have the new Override age restrictions: Allow permission can override
the block by selecting Continue. After staff overrides a block, the system does not
display another alert for the same material type in the current check-out session for the
same patron.

Minimum Age Blocks with Title-Level Hold
Requests
When library staff or a patron places a title-level hold request, Polaris evaluates all items
attached to the bibliographic record. If there are items with different material types, the
system generates a block using the item with the most restrictive age. For example, if
there is a DVD with a minimum age of 16 and a Blu-Ray disc with a minimum age of 18
attached to the same bibliographic record, the system only allows the title-level hold if
the patron is at least 18 years of age.

If there are no items attached to the bibliographic record, the system allows the title-
level hold. In this scenario, the patron might be blocked later at check-out if the item
filling the hold has a minimum age that would block the patron.

Setting Up Age-Related Loan Policies

Tip:
Innovative does not recommend setting up this feature unless your library
requires entering a birth date during patron registration. If a patron's
record does not have a value in the Birth Date field, the system assumes
the patron is too young and blocks check-outs and hold requests for all
material types that have aMinimum Age set. For information on setting
the Birth Date field as required during patron registration, see "Setting
Patron Registration Required Fields and Defaults" in the Polaris staff
client documentation.

To set up age-related loan policies

1. Determine which material types you want to restrict and the age limit for each.

2. In Polaris Administration (staff client), go to Administration Explorer > System >
Policy Tables >Material Types.
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The Material Types table appears.

3. For each material type you want to restrict, do the following:

a. Double-click the row for the material type.

b. Enter a value in theMinimum Age field.

c. Select OK.

4. Select Save.

5. Assign the Override age restrictions: Allow permission to staff who are authorized
to override Minimum age blocks.
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For information on assigning permissions, search the Polaris staff client help for
"Assign Permissions".
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Declaring Items Damaged in Leap
Leap now supports two different workflows for declaring items damaged.

This section covers the following topics:

l Declaring an Item Damaged at Check-In
l Declaring an Item Damaged From the Patron Record

Declaring an Item Damaged at Check-In

You can check in a damaged item from the Check In workform if the item's circulation
status is Out or In and you have the following permission settings in Polaris
Administration (staff client):

l Special item check in: Access
l Special item check in: Select damaged

For more information about these permissions, search for "Circulation Permissions" in
the Polaris staff client help.

To declare an item damaged at check-in

1. Select CHECK IN.

The Check In workform appears.

2. Select the Damaged view.

3. Do one of the following:

l Scan the barcode of the item you want to check in.
l Select FIND TOOL to search for and select the item you want to check in.

4. Select Enter .

The Declare Item Damaged dialog appears.
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5. Select one of the following options:

l Declare damaged: charge and notify - When you select this option, Leap
does the following:

o Checks the item in.
o Sets the item's circulation status to Damaged.
o If applicable, charges replacement and processing fees to the patron's

account.

Note:
If the item's status is In, Leap charges replacement and
processing fees to the account of the patron who last
borrowed the item.

o Sends a bill notice to notify the patron of the charges.
o Assigns a system-generated block ("Item is Damaged") to the item

record.

l Declare damaged: update item only - When you select this option, Leap does
the following:
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o Checks the item in.
o Sets the item's circulation status to Damaged.
o Assigns a system-generated block ("Item is Damaged") to the item

record.
6. To add a note that appears in the item record and on the bill notice, enter text in

the Special item check-in note box.

7. Select OK.

Leap processes the check-in according to the option you selected.

Declaring an Item Damaged From the Patron
Record

You can declare an item damaged from the Out/Overdue view of the patron record.

To declare an item damaged from the patron record

1. Open the patron record.

2. Select the Out/Overdue view.

Leap displays the patron's checked out items.

3. Select the item you want to declare damaged.

4. Select Declare Damaged.

The Declare Item Damaged dialog appears.
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5. For each type of fine or fee (replacement, processing, and overdue), select the
appropriate action from the Actions list.

6. (Optional) For each type of fine or fee, modify the Amount.

7. If the patron is paying a fine or fee, select a payment method from the Payment
method list.

Note:
Leap can accept credit card payments if your library has enabled
EnvisionWare or Comprise as the eCommerce payment gateway
and a credit card reader is attached to the workstation.

8. To send a bill notice for charges associated with the damaged item, select Send a
bill.

9. To add a message that appears on the bill notice, enter text in the Added message
box.

10. Select OK.
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Leap does the following:

l Sets the item's circulation status to Damaged.
l If applicable, charges fines or fees to the patron's account and accepts pay-
ments.

l Assigns a system-generated block ("Item is Damaged") to the item record.
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New Custom Menu Options in Leap
Leap now supports three new menu options that your library can choose to enable and
customize. Each menu option opens a website that your library specifies.

You can use the menu options to provide links from Leap to resources that your staff
members use, such as:

l SQL Server Reporting Services
l SimplyReports
l INN-Reach Central Catalog
l Your library's internal documentation

Two of the custom menu options appear on the Utilities menu when enabled.

The third option appears on the Help menu when enabled.
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By default, these menu options do not appear in the Leap user interface. For each menu
option, you can do the following:

l Enable the menu option.
l Specify the website that opens when a user selects the menu option.
l Modify or translate the menu option text.

Enabling a Custom Menu Option

Three new administrative profiles determine whether menu options appear in the Leap
user interface:

l Web App: Suppress Link: Custom 1
l Web App: Suppress Link: Custom 2
l Web App: Suppress Link: Library Documentation

You can set each profile at the system, library, or branch level in Polaris Administration
(staff client).

To enable a custom menu option

1. In Polaris Administration (staff client), go to Administration > Explorer.
2. Select an organization level (System, Library, or Branch).
3. Select Profiles > Staff Client.

4. Double-click theWeb App: Suppress Link profile you want to enable, then set the
Value option to No.
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By default, each profile is set to Yes.

5. Select Save .

Specifying the URL that Corresponds to a Menu
Option

Three new administrative profiles specify the URLs that correspond to each custom
menu option:

l Web App: Custom 1 URL
l Web App: Custom 2 URL
l Web App: Library Documentation URL

You can set each profile at the system, library, or branch level in Polaris Administration
(staff client).

To specify a URL for a custom menu option

1. In Polaris Administration (staff client), go to Administration > Explorer.
2. Select an organization level (System, Library, or Branch).
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3. Select Profiles > Staff Client.

4. Double-click the profile you want to configure, then enter a URL in the Value field.
The URL must begin with http:// or https://.

5. Select Save .

Modifying Menu Option Text

To modify or translate the menu option text that appear in the user interface, update the
following Staff Web Client string identifiers in the Web Admin (Language Editor) Tool: 

Default Menu Option Text String Identifier

Custom 1 SWC_CUSTOM_1

Custom 2 SWC_CUSTOM_2

Library Documentation SW_CI_LIBRARY_DOCUMENTATION



What's New in Polaris and Leap 7.5

© 2024 Innovative (Part of Clarivate)
Page 37

Using Leap's Improved Weeding Workflow
You can now use Leap to manage your weeding process. Leap offers a workflow with
permissions for staff and managers to take different roles while weeding item or
bibliographic records.

To complete the weeding workflow

1. Create a Weeding Template. To create a weeding template, you need theWeeding
templates: Create permission.

2. Delete a Weeding Template.

3. Create a Weeding Record Set.

4. Modify a Weeding Record Set by Adding or Removing Records.

5. Decide what Weeding Approval Process to Use.

6. Submit the Weeding Record Set for Review or Approval. To submit a weeding
record set for review or approval, you need theWeeding: Submit for approval
permission.

7. Approve or Decline a Weeding Record Set. To approve a weeding record set, you
need theWeeding: Approve permission. To decline a weeding record set, you need
theWeeding: Decline permission.

l Approved — On approval, records in each weeding record set can be set to
Withdrawn, can be marked Deleted, or can remain unchanged, depending on
the settings in the weeding template.

l Declined — On decline, a weeding record set restarts at: Modify a Weeding
Record Set by Adding or Removing Records.

8. Delete or Undelete a Weeding Record Set. To delete or undelete a weeding record
set, you need the Cataloging record sets: Delete/Undelete permission.

Creating a Weeding Template

A weeding template allows you to define criteria that Leap uses to verify items that you
add to a weeding record set. Using a weeding template's criteria, you can create a
weeding record set. You can create one or many weeding criteria sets for one weeding
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template. For each template, you can also set a discard amount for the weeding record
set.

Note:
To create a weeding template, you need the following permission:

Weeding templates: Create

To create a weeding template

1. Go to the Newmenu > Template >Weeding.

The New Weeding Template workform appears.

2. Enter a Name for the template, and select an Owner.

Using the Name, you can search for the template by name using the Find Tool. The
Owner limits the available templates when creating a weeding record set.

3. Select one of the following forMark Items Withdrawn:

l Never — (default) Leap never automatically changes the status of items in
the corresponding record set.

l Immediately —When you save, Leap automatically changes the status of all
items in the record set to Withdrawn.

l At Approval —When a final approver approves the record set (the last step in
the process), Leap automatically changes the status of all items in the
record set to Withdrawn.

4. (Optional) Select Alert for Last Copy if you want an alert to appear when a staff
member adds the last viable copy1 of an item to the weeding record set.
When this option is enabled, staff members adding to a weeding record set see a
notification indicating that the item is the last copy. An alert icon also appears
beside the record in the record set table.

5. (Optional) Select Delete Approved Items if you want Leap to mark all records in
the record set with the status Deleted when the weeding record set is approved. If

1Last viable copy could mean that this is the final item record in the system. It could
mean that all other copies are marked as missing or lost. It could also mean that this
record is the last copy in an unsupressed status.
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your library retains deleted item records, staff members can search for the items
and undelete them.

6. Select SAVE.

7. Select +ADD CRITERIA to add criteria that the system uses to validate items
added to the weeding record set.

A Weeding Criteria workform opens.

a. Enter a Name for the criteria set.

b. Enter a power search expression in the Inclusion Criteria box.

You can test your power search expressions by putting them in the search
bar of the Find Tool to see the results. For information on building power
search expressions, search the Leap help for "Do a Power Search."

c. (Optional) Select TEST CRITERIA to have Leap validate the syntax in the
Inclusion Criteria box.

A notification indicates if the power search syntax is correct or contains
errors.

d. Select Item Filters to limit the search further:

i. Creation dates — Enter a number in Newer Than or Older Than, then
select Years orMonths.

ii. Lifetime Circulation counts — Select Over or Under, and then type a
number in Lifetime Circulation or Lifetime In-House Circulation.

iii. Year-to-Date Circulation counts — Select Over or Under, and then type a
number in Year-to-Date Circulation or Year-to-Date In-House
Circulation.

e. Select SAVE.

8. (Optional) To delete a criteria set from the Weeding Template Details view, do the
following:

a. Select the checkbox beside the criteria set.

b. Select DELETE.
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Note:
You can delete a criteria set only if it is not in use by another
weeding template.

9. Select SAVE.

After criteria are added, staff can add item records to the weeding list. If Leap
detects a record in the weeding list that doesn't match the criteria, it rejects the
record and staff members receive a notification stating the record ID and that it is
not eligible for weeding.

Setting a Discard Amount
A discard amount allows you to assign a value to the items that are removed as the
result of a weeding list. You can set the source of the amount to one of three options.

To set a discard amount

1. Open the Weeding Template and select the Discard Amount view.

2. Select a Source:

l None – The discard amount is always zero. This is the default.

l Item Record Price – Let Leap calculate the Discard Amount based on the
price associated with the Item Record.

l Template – Set a discard amount based on the item language field in the
item record.

i. To add a row to the template table, select + ADD.

A template for Language and Amount appears.

ii. Select a Language and assign an Amount for items published in the
selected language.

iii. Select OK.

The row appears in the template table below.

iv. To delete a row, select the checkbox beside that row and select
DELETE.

3. Select SAVE.



What's New in Polaris and Leap 7.5

© 2024 Innovative (Part of Clarivate)
Page 41

Deleting a Weeding Template

To delete a weeding template

1. Delete all weeding record sets linked to the weeding template.

If one weeding record set still uses this template, you cannot delete it.

2. View the Weeding Template workform.

3. Select the Actionsmenu.

4. Select Delete.

The Delete Weeding Template dialog opens.

5. Select Continue.

Creating an Empty Weeding Record Set

To create a empty record set

1. Select New > Record Set.

A New Record Set dialog appears.

2. From the Record Type list, selectWeeding.
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3. From theWeeding Template list, select a template. To create a weeding template,
see Create a Weeding Template.

4. Select OK.

A New Weeding Record Set workform opens.

5. Enter a Name.

6. (Optional) Enter a note in the Note box.

7. Select SAVE.

Modifying a Weeding Record Set by Adding or
Removing Records

To add records to a record set

1. Open the record set in the Weeding Record Set workform.
2. To select the record or records to add, use one of these methods:

l Select FIND to open the Find Tool with the appropriate record type selected.
Search for and select the records to add. Select OPEN.

l Scan or type the barcode. The Scan or enter barcode option is available for
all record set types except for authority record sets. You can scan or type a
barcode to add an item record to a weeding record set.
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Note:
If you try to add any records that already belong to the record set, a
notification informs you that duplicates were found. The notification
also displays the number of records that were actually added.

3. To add records from a file, select ACTIONS > Add from file.

The Weeding Record Set workform appears with the records added to it.

To remove records from a record set

1. Search for and select the record set you want to modify.

The Weeding Record Set workform appears.

2. Select the checkboxes beside the records you want to remove.
3. Select ACTIONS above the list, and select Remove Selected Records.

The records are removed from the record set, but remain in the Polaris database.
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Deciding what Weeding Approval Process to
Use

After creating a weeding record set, a staff member can send the weeding record set for
one or two rounds of approval, depending on your library's preferred process.

l Two rounds of approval — Use Submit for Review if you want weeding record sets
to go through two levels of approval.

a. Use Submit for Review as the first round of approval. This changes the
status of the record set to In Review and the record set moves to the
Approval Dashboard.

b. The reviewer uses the Approval Dashboard to approve or decline the
weeding record set. Approval changes the status of the record set from In
Review to Approval Requested.

c. The approver uses the approval dashboard or the weeding record set
workform to approve or decline the weeding record set. Approval changes
the status of the record set from Approval Requested to Approved.

l One round of approval — Use Submit for Approval as the first round of approval if
you want weeding record sets to go through one level of approval.

a. Use Submit for Approval as the first round of approval if your library uses
one round of approval, skipping the Submit for Review step. This changes
the status of the record set to Approval Requested and the record set moves
to the Approval Dashboard.

b. The approver uses the approval dashboard or the weeding record set
workform to approve or decline the weeding record set. Approval changes
the status of the record set from Approval Requested to Approved.
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Submitting the Weeding Record Set for Review
or Approval

To submit a weeding record set for review or approval

1. Use the Find Tool to find the weeding record set you want to submit.

2. Open the weeding record set.

3. Review and adjust the item list. You can:

a. View the properties of one weeding record at a time.

l Select the checkbox beside the record you want to view.

l Select ACTIONS > Properties.

b. Filter the list by typing a keyword to filter by in the Filter field.

c. Add more records.

l To scan in, find records, or add records from a file, see Modify a
Weeding Record Set by Adding or Removing Records.

d. Remove records.

l Select the checkbox beside each record you want to remove.

l Select ACTIONS > Remove Selected Records.

4. Select SAVE.

5. Select ACTIONS for the record set.

6. Select one of the following:

l Submit for Review – Requires Cataloging record sets: Modify permission.
Select this option to send the weeding record set to a reviewer for the first
round of review, if you're using two rounds of approval.

l Submit for Approval – RequiresWeeding: Submit for approval permission.
Select this option to send the weeding record set for final approval.
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If you select Submit for Review, the status of the record set changes to In
Review, and the record set moves to the Approval Dashboard. In the
Approval Dashboard, the reviewer can approve or decline the weeding list. In
the Weeding Record Set workform the reviewer can submit the record set for
approval, or decline the weeding list.

If you select Submit for Approval, the status of the record set changes to
Approval Requested, and the record set moves to the Approval Dashboard. In
the Approval Dashboard, the reviewer can approve or decline the weeding
list.

Approving or Declining a Weeding Record Set

Reviewers and approvers can approve or decline weeding record sets using one of the
following methods:

l Approval Dashboard — You can approve (or decline) multiple weeding record sets
at once.

l Weeding Record Set workform — You can review the list of records, and add or
delete records before you approve or decline the individual weeding record set.

Using the Approval Dashboard to Approve or
Decline

Note:
To approve a weeding record set, you need theWeeding:
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Approve permission. To decline a weeding record set, you need the
Weeding: Decline permission.

To approve or decline a weeding record set using the Approval Dashboard

1. To open the Approval Dashboard, go to Utilities > Approval Dashboard.

The Weeding Requests tab of the dashboard appears in the Active Requests view.

2. (Optional) Filter or sort the list of weeding requests.

a. To filter the list by record status, select a status from the Status list.

b. To filter by keyword, type a keyword in the Filter box.

c. To sort the list, select a column header.

3. Select the checkbox beside each weeding list you want to approve or decline.

Leap enables the APPROVE and DECLINE buttons.

4. Select one of the following:

l APPROVE – Select this option to approve the weeding record sets. Records
in the weeding record set are set toWithdrawn, or are marked Deleted,
depending on the settings in the weeding template.

l DECLINE – Select this option to send records in the weeding record set back
to the original state of Pending, so staff can do more work on them.

Using the Weeding Record Set Workform
To approve or decline a weeding record set using the Weeding Record Set workform

1. Use the Find Tool to find the weeding record set you want to approve or decline.

2. Open the Weeding Record Set workform.

3. Select ACTIONS for the record set.
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4. Select one of the following:

a. Approve – Select this option to approve the weeding record set. Records in
the weeding record set are set toWithdrawn, or are marked Deleted,
depending on the settings in the weeding template.

b. Decline – Select this option to send records in the weeding record set back
to the original state of Pending, so staff can do more work on them.
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Deleting or Undeleting a Weeding Record Set

You can delete or undelete a weeding record set like you can an item record set.

Note:
To delete or undelete a weeding record set, you need the Cataloging
record sets: Delete/Undelete permission.

To delete a weeding record set

1. Open the weeding record in the Weeding Record Set workform.

2. Select Actions > Delete.

One of the following messages appears, depending on your library's setting for the
profile Retain deleted item records:

l The weeding record will be marked for deletion. Do you want to continue?

l The weeding record will be permanently deleted. Do you want to continue?

3. Select CONTINUE to delete the weeding record set.
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The item is either marked for deletion and retained, or it's permanently deleted
from the database, depending on the profile setting.

4. (Optional) To permanently delete the weeding record set regardless of the profile
setting, select Actions > Delete a second time.

To undelete a weeding record set

1. Open a deleted weeding record set in the Weeding Record Set workform.

2. Select Actions > Undelete.

Leap updates the weeding record set as follows:

l Sets the record status to Final.

l Displays the username as the modifier.

l Displays the modification date as the undelete date.

l Selects the Display in PAC checkbox.

l Adds an undeleted row to the item record history.

l Logs a weeding record undeleted transaction (9012).
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Using the New Waiver Workflow
The new waiver workflow gives you more granular control over the process of waiving
an amount charged to a patron's account. Using this new workflow, you can designate
staff members who can oversee the waiver process by approving or declining a waiver
request. Staff members who don't have permission to waive fees can start the process
by requesting a waiver approval.

Important:
To use the new waiver workflow, you must remove the old waive
permission (Fines: waive fines at circ), and set the following system-level
permissions for staff members:

l Fines: Submit waiver requests
l Fines: Approve waiver requests for user threshold
l Fines: Decline waiver requests

This topic covers the following:

1. Setting Up the New Waiver Workflow in Polaris Administration (staff client).

2. Using the New Waiver Workflow in Leap.

Setting Up the New Waiver Workflow

You can set up the New waiver workflow in Polaris Administration (staff client) using
the following steps:

1. Enable the new waiver workflow.

2. Set the maximum waiver amount that each staff member can approve.

3. Add reasons to the policy table User Defined Waiver Request Reasons.
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Enabling the New Waiver Workflow
To enable the new waiver workflow

1. In Polaris Administration (staff client), select Administration > Explorer.

2. Select System > Profiles > Staff Client.

3. Double-click theWeb App: Use waiver request action profile set the value to Yes.

4. Select Save.

When you enable this option, Leap replaces the current Waive action on the patron
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account with a Waiver Request form.

Setting the Maximum Waiver Amount
You can set the waiver threshold, which is the maximum dollar amount that each staff
member is allowed to waive at one time.

To set the waiver threshold

1. In Polaris Administration (staff client), select Administration > Staff Member.

2. Search for a staff member and open the staff member workform.

3. Select View > Profiles > Patron Services.
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The user-level profile appears with the waiver approval threshold set to $0.00.
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4. Double-click to edit the dollar amount.

5. Select Save.

In the example above, this staff member can approve a waiver request for up to
$100.00.

Adding Waiver Reasons to the Policy Table
The waiver reasons are blank by default so that libraries can configure their own
reasons that they might waive a fee. This table is blank by default.

To configure waiver reasons

1. In Polaris Administration (staff client), select Administration > Explorer.

2. Select Policy Tables > User Defined Waiver Request Reasons.
The User Defined Waiver Request Reasons policy table opens.
This table is empty by default.

3. Select Insert to add each reason staff can select in Leap when requesting a
waiver.



What's New in Polaris and Leap 7.5

© 2024 Innovative (Part of Clarivate)
Page 56

4. (Optional) Modify or delete reasons from this table.

You can't delete a reason if a record uses it.

5. Select Save.

Leap displays these reasons in the Reason list on the waiver request form.
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Using the New Waiver Process in Leap

The waiver request workflow involves the following steps:

1. A patron requests a waiver for one of their fines.

2. An Authorized staff member submits a waiver request using the Waiver Request
form.

To access the Waiver Request form, you need Fines: Submit waiver requests
permission.

3. Overseeing staff approves or declines the waiver request.

To approve a waiver request, you need the Fines: Approve waiver requests for
user threshold permission. To decline a waiver request, you need the Fines:
Decline waiver requests permission.

When you approve or decline a waiver, the following happens:

l Approved — the amount requested is waived and removed from the patron's
account.

l Declined — the charge remains on the patron account.
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Submitting a Waiver Request
To submit a waiver request

1. In Leap, use the Find Tool to find the patron who wants a waiver.

2. To open the patron record workform, double-click the patron in the search results.
The patron record workform appears.

3. Select the Account view.

4. Select the check box beside the charges you want to waive.

5. SelectWaiver Request.
The area below the buttons expands to show the Waiver Request Form.

6. Fill in the form information:

l (Optional) Change the Amount to waive. By default, Leap lists the entire
amount of the charge.

l Select a Reason.

l (Optional) Enter a Note.

7. Select REQUEST WAIVER.
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The Waiver column appears in the patron's account table. This column has a
check mark in it if there is a pending waiver request for the charge.

Note:
When a waiver request is in progress, Leap doesn't allow:

l A staff member to start a new waiver request.

l A patron to pay the fee in question.

The waiver request moves to the Approval Dashboard.

Approving or Declining a Waiver Request
To approve or decline a waiver request

1. To open the Approval Dashboard, go to Utilities > Approval Dashboard.

The Weeding Requests tab of the dashboard appears.

2. SelectWaiver Requests.

The Waiver Requests tab of the dashboard appears in the Active Requests view.

3. (Optional) Filter or sort the list of waiver requests.
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l To filter by keyword, type a keyword in the Filter box.

l To sort the list, select a column header.

4. Select the checkbox beside the waiver request you want to approve or decline.

Leap enables the REVIEW button.

5. Select REVIEW.

The Review Waiver Request ID dialog opens.

6. Review the waiver request information.

7. (Optional) Enter an explanation in the Decision Note field.

8. Select one of the following:

l APPROVE – Select this option to approve the waiver request. The waiver
request is set to a status of Approved, and Leap removes the charge from
the patron's account.
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l DECLINE – Select this option to leave the charge on the patron's account.
The waiver request is set to a status of Declined.
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Using the Weeding and Waiver Approval
Dashboard
The Approval Dashboard gives reviewers and approvers an overview of their to do lists
for weeding and waiver requests. Reviewers can move one request or multiple requests
to the next level for approval. Staff at the end of the review process can also approve or
decline requests to conclude the process.

The Approval Dashboard contains two tabs:

l Weeding Requests

l Waiver Requests

Weeding Requests

The Weeding Requests tab gives reviewers and approvers one place to approve or
decline weeding record sets. This view is limited to records within each staff member's
logon branch.

To filter weeding record sets

l By view – Select the arrow beside the current view and select a new view.

l By record status – Select the arrow beside the current status and select a new
status.
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Note:
You can update your workform user defaults to ensure Leap always
filters your weeding requests by the same status.

l By keyword – Enter a keyword in the Filter box.

To update your workform user defaults

1. In Leap, select your username, and select Settings.

The Settings page opens.

2. Select theWorkform User Defaults tab.
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3. To specify the default weeding request status that appears in the Approval Dash-
board, select a status from theWeeding Requests list.

4. Select SAVE.

To approve or decline a weeding record set using the Approval Dashboard

Note:
To approve a weeding record set, you need theWeeding: Approve
permission. To decline a weeding record set, you need theWeeding:
Decline permission.

1. To open the Approval Dashboard, go to Utilities > Approval Dashboard.

The Weeding Requests tab of the dashboard appears in the Active Requests view.

2. (Optional) Filter or sort the list of weeding requests.

a. To filter the list by record status, select a status from the Status list.

b. To filter by keyword, type a keyword in the Filter box.

c. To sort the list by column, select a column header.

3. Select the checkbox beside each weeding list you want to approve or decline.

Leap enables the APPROVE and DECLINE buttons.

4. Select one of the following:
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l APPROVE – Select this option to approve the weeding record sets. On
approval, records in each weeding record set can be set to Withdrawn, can
be marked Deleted, or can remain unchanged, depending on the settings in
the weeding template.

l DECLINE – Select this option to send records in the weeding record set back
to the original status of Pending, so staff can do more work on them.

Waiver Requests

The Waiver Requests tab gives requesters and approvers one place to look for waiver
requests. It gives you one place to approve or decline a waiver request.

To filter waiver requests

l By view – Select the arrow beside the current view and select a new view.
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l By keyword – Enter a keyword in the Filter box.

To approve or decline a waiver request using the Approval Dashboard

1. To open the Approval Dashboard, go to Utilities > Approval Dashboard.

The Weeding Requests tab of the dashboard appears.

2. SelectWaiver Requests.

The Waiver Requests tab of the dashboard appears in the Active Requests view.

3. (Optional) Filter or sort the list of waiver requests.

a. To filter by keyword, type a keyword in the Filter box.

b. To sort the list, select a column header.

4. Select the checkbox beside the waiver request you want to approve or decline.

Leap enables the REVIEW button.

5. Select REVIEW.

The Review Waiver Request ID dialog opens.
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6. Review the waiver request information.

7. (Optional) Enter an explanation in Decision Note.

8. Select one of the following:

l APPROVE – Select this option to approve the waiver request. The waiver
request is set to a status of Approved and Leap removes the charge from the
patron's account.

l DECLINE – Select this option to leave the charge on the patron's account.
The waiver request is set to a status of Declined.
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Managing Extended Loan Periods
Your library can now offer extended loan periods on one or more collections to selected
patrons, so they have a longer time period to return these items.

To receive the Extended Loan Period

1. Setting Up Extended Loan Periods in Polaris Administration (Staff Client) – The
Library administrator must enable Extended Loan Period, configure Additional
Loan Units for chosen collections, and assign the permission Patron Privileges:
Modify to certain Leap users.

2. Selecting in Leap – Library staff must have the permission Patron Privileges:
Modify and select Extended Loan Period on the patron record in Leap.

3. Patron Check-Out – The patron must check out an item from a collection with
Additional Loan Units configured.

If all three conditions are met, the checkout due date includes the Additional Loan Units.

Setting Up Extended Loan Periods in Polaris
Administration (Staff Client)

To enable Extended Loan Period and configure Additional Loan Units

1. To display the Extended Loan Periods checkbox in Leap, set the following profile
setting to No: Profiles > Staff Client > Web App: Suppress Field: Extended Loan
Periods.



What's New in Polaris and Leap 7.5

© 2024 Innovative (Part of Clarivate)
Page 69

2. To configure Additional Loan Units:
a. Go to Polaris Administration (staff client) > Collection, and search for the

chosen collection.
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b. Select the collection to open the Collections workform.

c. Type a number in the Additional Loan Units field to increase the loan units
(amount of time) allowed for items in the collection. Polaris calculates the
loan period for the collection as follows: Base Units + Additional Loan Units.

Tip:
To find the Base Units for a collection, go to the Loan Periods
table of the governing library. In Polaris Administration (staff
client), select Branch > BranchName > Policy Tables > Loan
Periods. The Loan Periods policy table displays the Time Unit
and the base number of Units for the selected branch. In the
example below, the Base Units is 14 Days.
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3. Assign the permission Patron Privileges: Modify to Leap users who need to select
Extended Loan Period on Leap's patron record, Preferences section.

For information on assigning permissions, search the Polaris staff client help for
"Assign Permissions", and see "Add a Staff Member" in the Polaris System
Administration (Web-Based) guide.

Selecting in Leap

To select Extended Loan Period on the patron record in Leap

1. Ensure you have the permission Patron privileges: Modify.
Contact your Polaris Administrator with questions.

2. In Leap, use the Find Tool to find the patron.

3. Open the Patron Record > Registration View, and scroll to the Preferences sec-
tion.
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4. Select Extended Loan Period.

Patron Check-Out

A patron can use any method to check out an item from a collection that has Additional
Loan Units configured. Polaris uses the patron preferences, base units, and additional
loan units to calculate the appropriate due date.

The following examples are for patrons with the same home library and branch:

Patron Base Units
Has Exten-
ded Loan
Periods?

Additional
Loan Units
in Collection

Total loan
period

Patron 1 14 days Yes 12 days 26 days

Patron 2 14 days No 12 days 14 days
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Patron Base Units
Has Exten-
ded Loan
Periods?

Additional
Loan Units
in Collection

Total loan
period

Patron 3 14 days Yes 0 days 14 days
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Increasing Check-out Limits by Branch
Using the increased check-out limits feature, your library now can increase the total item
limit and material type limits for patrons at a branch. The branch can enable the feature
for specific patrons through the preference settings in the patron record. Once enabled
for a patron, the increased limits apply to all check-out transactions regardless of what
Polaris application the patron uses for check-out (for example, Leap, the Polaris staff
client, ExpressCheck, and Polaris API).

Tip:
Increased check-out limits do not apply to integrated eContent because
the vendors control the loan limits for those items.

This section covers the following topics:

l Setting Up Increased Check-out Limits

l Determining Base Check-out Limits

l How Increased Check-out Limits Work

Setting Up Increased Check-out Limits

The process of setting up increased check-out limits involves configuring settings in
Polaris Administration (staff client) at both the system and branch level and enabling
the option in Leap for individual patrons.

To set up increased check-out limits

1. Enable a system-wide setting for the increased check-out feature.

a. In Polaris Administration (staff client), go to Administration Explorer >
System > Profiles.

b. Select the Staff Client tab.

c. Locate the Web App: Suppress Field: Increased Check-out Limit profile
setting. This setting displays the Increased Check Out Limits checkbox in
Leap, which library staff use to enable this feature for individual patrons.
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d. Change the value to No.

e. Select Save.

2. Configure the increased check-out limits for each participating branch.

Note:
You must have theModify increased check-out limits: Allow
permission to complete this section.

Configuring increased check-out limits for a branch involves setting two branch-
level settings. Before you begin, however you might want to determine the base
check-out limits currently set for each branch.

a. In Polaris Administration (staff client), go to Administration Explorer >
[Branch Name] > Parameters.

b. Select the Patron Services tab, and locate the Check-out: Increase Total Item
Limit parameter. This parameter defines the number of items a patron can
check out in addition to the total item limit defined in the Patron/Material
Type Loan Limit Blocks policy table.

c. Enter the number by which you want to increase total check-outs.

d. Select Save.

e. In Polaris Administration (staff client), go to Administration Explorer >
[Branch Name] > Policy Tables > Increased Check-out Limits.

This table allows you to specify which material types can have increased
check-outs. When you enter a value in this table for a specific material type,
the system adds this number to the maximum item limit defined for that
material type in the Patron/Material Type Loan Limit Blocks policy table. If a
material type does not appear in this table, then no increased check-outs are
allowed for that material type.

Warning:
Both the Increased Check-out Limits policy table and the
Check-out: Increase Total Item Limit parameter above must be
configured for this feature to work properly.

f. Select Insert .
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The Insert: Increased Check-out Limits dialog appears.

g. Select a material type from the list, and enter the number of increased check-
outs allowed.

h. Repeat the last two steps to add additional material types.

i. Select Save.

3. Enable the increased check-out feature for individual patrons.

Note:
You must have the Patron privileges: Modify permission to
complete this section.

a. In Leap, use the Find Tool to find the patron.

b. Open the patron record, and select Registration.

c. Select the Preferences tab on the left side of the screen.

d. Select Increased Check Out Limit.
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e. Select Save.

Determining Base Check-out Limits

Prior to configuring increased check-out limits, you can review the base check-out limits
already set in your system.

To determine base check-out limits

1. In Polaris Administration (staff client), go to Administration Explorer > [Branch
Name] > Policy Tables > Patron/Material Type Loan Limit Blocks.

The Patron/Material Type Loan Limit Blocks table appears.
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2. View the following information:

l In the upper pane, the Total Item Limit appears for each patron type. The
setting in the Check-out: Increase Total Item Limit parameter increases this
amount.

l When you select a patron type in the upper pane, the lower pane displays the
maximum item limit by material type for that patron type. The settings in the
Increased Check-out Limits policy table increase these amounts.

Note:
The system-level Patron Services parameter Consortium Circulation
determines which branch’s settings are used for loan limit blocks. For
details, see "Governing Library for Circulation Transactions" in the Polaris
staff client documentation.
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How Increased Check-out Limits Work

During check-out transactions, Polaris does the following to apply increased check-out
limits:

1. Base Check-out Limits -- Determines the base check-out limit and base material
type limit using the Patron/Material Type Loan Limit Blocks policy table.

l If the check-out does not exceed either limit, the transaction is allowed.

l If the check-out exceeds one or both of the limits, the system proceeds to
the next step.

Note:
The system-level Consortium Circulation parameter determines which
branch’s settings are used for determining the base check-out limits. For
details, see "Governing Library for Circulation Transactions" in the Polaris
staff client documentation.

2. Increased Check-out Limits -- Determines if increased check-out limits apply to
the current transaction as follows:

l Determines whether the patron is enabled for increased check-out limits
using the Increased Check Out Limit setting in the Preferences section of
the patron record.

l Determines if an increased total item limit is configured for the branch using
the Check-out: Increase Total Item Limit parameter. If so, it adds this number
to the base total item limit.

l Determines if an increased material type limit is configured for the branch
using the Increased Check-out Limits policy table. If so, it adds this number
to the base material type limit.

Once the increased check-out limits are determined, the system proceeds to the
next step.

Note:
The settings that determine the increased total item limit and increased
material type limit are branch-level settings that use the item's assigned
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branch. This might differ from the transacting branch or patron's branch
that determines the base check-out limits in step 1.

3. Material Type Limit Check -- Checks whether the transaction exceeds the material
type limit as follows:

l If the check-out does not exceed the increased material type item limit,
proceeds to the next step.

l If the check-out exceeds the increased material type limit, displays a block
message. Staff can override the block and continue with the transaction if
they have Override item limit blocks: Allow permission.

4. Total Item Limit Check -- Checks whether the total item limit has been exceeded
as follows:

l If the check-out does not exceed the increased total item limit, the
transaction is allowed.

l If the check-out exceeds the total item limit, displays a block message. Staff
can override the block and continue with the transaction if they have
Override item limit blocks: Allow permission.

Examples
The examples below assume that the governing library for patron blocks is set to use
the transacting branch (Main) and that all items being checked out are also from the
Main branch. The relevant settings from Polaris Administration (staff client) for the
Main branch are:

Table / Parameter Setting Value

Patron/Material Type Loan Limit Blocks policy
table

Total Item Limit 5

Maximum Item Limit
(book)

5

Maximum Item Limit
(DVD)

2

Maximum Item Limit
(laptop)

1

Check-out: Increase Total Item Limit n/a 2
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parameter

Increased Check-out Limits policy table Book 2

Example 1

Requested transaction: A patron currently has 5 books checked out and wants to check
out another book.

System response: This transaction exceeds the base material type limit and the base
total item limit, so the system looks at the settings for increased check-out limits and
determines:

l The patron is enabled for increased check-out limits.

l The branch is configured for 2 additional items (for an increased total item limit of
7).

l Of the 2 additional items allowed, both can be books (for an increased material
type limit of 7 for books).

Because the additional book is from a branch configured for increased check-outs, the
transaction is allowed. If the item is from a branch that is not configured for increased
check-outs, the system displays a block message.

Example 2

Requested transaction: A patron currently has 3 books and 2 DVDs checked out and
wants to check out another DVD.

System response: This transaction exceeds the base material type limit for DVDs and
the base total item limit, so the system looks at the settings for increased check-out
limits and determines:

l The patron is enabled for increased check-out limits.

l The branch is configured for 2 additional items (for an increased total item limit of
7).

l DVDs are not configured for increased check-out limits.

The system displays a material type limit block message. Even though the patron can
check out two additional items, the material type of those items must be configured in
the Increased Check-out Limits policy table. Otherwise, the base material type limits
apply.
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Example 3

Requested transaction: A patron currently has 5 books checked out and wants to check
out a laptop.

System response: This transaction exceeds the base total item limit, so the system
looks at the settings for increased check-out limits and determines:

l The patron is enabled for increased check-out limits.

l The branch is configured for 2 additional items (for an increased total item limit of
7).

The check-out does not exceed the increased total item limit, so the transaction is
allowed. Although laptops are not a material type configured in the Increased Check-out
Limits policy table, the patron is still entitled to check out one laptop as part of the base
material type limits.
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Searching for Bibliographic Records by
National Bibliography Number
You can now search for bibliographic records by national bibliography number (NBN) in
Leap.

A new NBN basic search option appears in the Bibliographic Record Find Tool.

When you select the NBN search option, Leap finds bibliographic records with an 015
tag subfield $a that matches your search term.

You can also filter a bibliographic record search by NBN.

To translate or change the search option label that appears in the user interface, update
the following Staff Web Client string identifier in the Web Admin (Language Editor)
Tool: ERMS_TK_QUALIFIER_BR_NBN.
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Leap Performance Improvements for
Bibliographic Records with Thousands of
Items
In previous versions, Leap sometimes became unresponsive when you attempted to
view items for a bibliographic record with thousands of linked items.

Version 7.5 includes performance updates that improve Leap's ability to display
bibliographic records with many items. Leap now successfully displays the All Items
view of the Bibliographic Record workform for a bib record with thousands of linked
item records.
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Using Volume Level Holds
You can allow staff and patrons to place holds on the first available copy of the
following in the Polaris staff client, Leap, or PowerPAC:

l Integrated serials
l Multi-part sets
l Non-integrated serials

This topic covers the following:

l Setting Up Volume Level Holds
l Placing a Volume Level Hold in Leap
l Placing a Request for a Non-Integrated Serial Volume in PowerPAC

Note:
To place any type of hold in PowerPAC, see "Request Materials" in the
PowerPAC help.

Setting Up Volume Level Holds

To set up volume level holds

1. In Polaris Administration (staff client), go to Administration Explorer > System >
Parameters.

2. Select the Request tab.

3. Open Holds options.

The Hold Options dialog opens showing the Requests tab.

4. In the Manage Item Requests section, select Limit item requests to first available
copy and select one of the following:

l Allow requests on integrated serials in PAC and Staff Client — to allow
requests on serials cataloged in the Polaris serials module.
Use this setting if your library uses the Polaris serials module.
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l Allow requests on multi-part sets and non-integrated serials in PAC and
Staff Client — to allow requests on volumes of multi-part bibliographic items
and serials not cataloged in the Polaris serials module (non-integrated
serials).
Use this setting if your library doesn't use the Polaris serials module, but you
want to allow staff and patrons to request a hold on a specific volume or
date of a multi-part title, and not just the title as a whole.

l All — to allow requests on serials cataloged in the Polaris serials module,
serials not cataloged in the Polaris serials module, and volumes of multi-part
bibliographic items.
Use this setting if your library uses the Polaris serials module and you also
allow staff and patrons to request a hold on a specific volume or date of a
multi-part title.

5. Select Apply and then select OK.
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Placing a Volume Level Hold in Leap

To place a volume level hold in Leap

1. Open a patron record and select Holds / Held.

2. Select New Hold.

The New Hold area expands.

3. Select FIND TOOL.
4. Search for and open a title with multiple volumes.

5. Select OPEN.

The Find Tool populates the Title and other fields for the selected bibliographic
record.

6. Select PLACE HOLD.

The Serial/Multi Volume Holds dialog opens.

7. Select one of the following:

l Request any item
l Request the first available copy of one of the listed items and select a spe-
cific volume from the list.

8. Select CONTINUE.
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Leap creates the hold request and adds the title and volume to the Holds list.

Placing a Request for a Non-Integrated Serial
Volume in PowerPAC

This section describes the patron workflow for placing a request on a volume of a serial
that is not cataloged in the Polaris serials module.

Note:

This workflow applies when both of the following conditions are true:

l Your library has configured the Hold Options parameter to allow
requests on volumes of serials that are not cataloged in the Polaris
serials module.

l The patron requests a volume that is associated with a bibliographic
record that meets the following criteria:

o The record has a Leader 07 value of s.
o Items attached to the bibliographic record contain volume

information.
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To place a request on a volume of a serial that is not cataloged in the serials module

1. In PowerPAC, search for a title.

2. Select PLACE REQUEST.

PowerPAC displays a list of volumes associated with the title.

3. Select Place Request for the volume you want to request.

PowerPAC displays the standard request form.
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4. Configure additional request options and select Submit Request.
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Charging Overdue Fines on Library Closed
Dates
In previous versions, you could choose whether Polaris charges overdue fines on days
of the week that the library is closed. As of version 7.5, you can now also choose to
charge overdue fines on dates that the library is closed (for example, holidays).

The days that your library is closed are defined in the Hours of operation parameter. The
Days not fineable parameter controls whether overdue fines are charged on days that
the library is closed. Both parameters are found on the Patron Services tab in Polaris
Administration (staff client).

The dates that your library is closed are defined in the Dates Closed policy table in
Polaris Administration (staff client). A closed date is a specific date that the library is
closed that is an exception to the library’s normal hours of operation. The new
Overdues: Charge fines for dates closed parameter controls whether overdue fines are
charged on closed dates. You can set this parameter at the system level in Polaris
Administration (staff client).

Note:
By default, Polaris does not charge overdue fines on closed dates. If you
want to use this default behavior, you don't need to take any action.

The sections below explain how to configure and use this feature:

l Configuring Polaris to Charge Overdue Fines on Closed Dates
l Other Factors that Affect Overdue Fines on Closed Dates

Configuring Polaris to Charge Overdue Fines on
Closed Dates

To configure Polaris to charge overdue fines on closed dates

1. In Polaris Administration (staff client), go to Administration > Explorer > System.
2. In the Administration Explorer - System tree list view, double-click the system

name to expand the list.
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3. Select Parameters > Patron Services.

The patron services system parameters appear.

4. Double-click the Overdues: Charge fines for dates closed parameter, and set the
Value option to Yes. By default, the parameter is set to No.

5. Select Save .

Other Factors that Affect Overdue Fines on
Closed Dates

The Consortium Circulation parameter also affects how Polaris calculates overdue fines
on closed dates. This parameter determines which branch’s closed dates Polaris uses
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when calculating overdue fines. For more information, search for "Governing Library for
Circulation Transactions" in the Polaris staff client help.
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Logging Transactions for Patron Blocks
You can now configure Polaris to log transactions when staff-generated blocks (library-
assigned blocks or free-text blocks) are added to or removed from patron records.

Logging transactions for patron blocks makes it possible to retain an audit trail of the
blocks added to patron accounts, even after the blocks have been removed.

To configure transaction logging for patron blocks

1. In Polaris Administration (staff client), go to Administration > Explorer.

2. Select an organization level (System, Library, or Branch).

3. In the Administration Explorer tree list view, double-click the system, library, or
branch name to expand the list.

4. Double-click Database Tables to expand the list.

5. Select Transaction Logging.

Polaris displays a list of transaction types. You can select the Transaction
Description column heading to sort the list.
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6. Double-click the Patron block added transaction type, and set the Log Transaction
value to Yes or No. By default, the value is set to Yes.

7. Double-click the Patron block deleted transaction type, and set the Log
Transaction value to Yes or No. By default, the value is set to Yes.

8. Select Save .
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Configuring Polaris to Automatically Clear
Object Locks
You can now configure Polaris to automatically clear object lock entries that are more
than a certain number of hours old. This reduces the likelihood of staff members
encountering unintentionally locked records while working in Leap or the staff client. It
also saves time for the staff members tasked with manually clearing object lock entries.

You can enable the new Clear Object Locks SQL job, which clears entries from the
Object Locks database table when it runs. The new Automated object lock clearing:
Age of lock to clear profile specifies which object lock entries the SQL job removes.

This section covers the following topics:

l Working with the Clear Object Locks SQL Job
l Configuring the Automated object lock clearing: Age of lock Profile

Working with the Clear Object Locks SQL Job

When enabled, the Clear Object Locks SQL job runs hourly and removes entries in the
Object Locks database table that are older than the number of hours specified in the
Automated object lock clearing: Age of lock to clear profile.

By default, this SQL job is disabled.

Configuring the Automated object lock
clearing: Age of lock Profile

Edit the Automated object lock clearing: Age of lock to clear profile to specify which
object lock entries the Clear Object Locks SQL job removes.
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To configure the Automated object lock clearing: Age of lock profile

1. In the Polaris shortcut bar, select Administration > Explorer > System.
2. In the Administration Explorer - System tree list view, double-click the system

name to expand the list.
3. Select Profiles > Staff Client.

4. Double-click the Automated object lock clearing: Age of lock to clear profile, and
set the Value option to a number of hours between 1 and 72.

By default, the profile is set to 12. If you set the profile to 0, the Clear Object Locks
SQL job does not remove any object lock entries.

Note:
Be aware that setting this profile to a smaller number, such as 1 or
2, increases the likelihood that the Clear Object Locks SQL job might
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remove an object lock entry for a record that a staff member is
actively editing.

5. Select Save .
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Support for Basic OAuth 2.0
Authentication in Leap
Leap now supports the use of basic OAuth 2.0 for single sign-on (SSO) authentication.
Unlike standard OAuth 2.0, basic OAuth 2.0 does not use OpenID Connect (OIDC) or
Proof Key for Code Exchange (PKCE). In addition, basic OAuth 2.0 does not rely on
claims found within a JSON web token (JWT). Instead, it exchanges an access token
(typically, an opaque token) to retrieve claims from the OAuth /userinfo endpoint.

Contact Innovative for help getting started with basic OAuth 2.0 authentication.
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New External ID Field on the Staff Member
Workform
If your library's process for authenticating staff members requires an external ID, you
can now add the ID to the staff member record. Depending on your library's process, the
external ID may be used during authentication when a staff member signs in to Leap or
Polaris System Administration (web-based).

Note:
For more information about configuring authentication for Leap or Polaris
System Administration (web-based), see the Polaris and OAuth 2.0 with
OpenID Connect Integration Guide.

The External ID field corresponds to the ExternalID value in the PolarisUsers database
table. If you update the External ID field, Polaris writes your changes to the database.

An external ID maps a Polaris staff member to an ID used or provided by an external
identity provider.

This section covers the following topics:

l How the Authentication Process Uses the External ID
l Adding an External ID to a Staff Member in Polaris Administration (Staff Client)
l Adding an External ID to a Staff Member in Polaris Administration (Web-Based)

How the Authentication Process Uses the
External ID

Staff member authentication for Leap and for Polaris System Administration (web-
based) is handled by one of the following identity providers:

l Active Directory and Active Directory Federation Services (AD FS)
l Azure Active Directory (Azure AD)
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By default, during authentication, the system uses the user principal name (UPN) in the
format of an email address to map a Polaris staff member to the corresponding Active
Directory user or Azure AD user.

However, if an identity provider returns an ID that is not a UPN, or a UPN that is not in the
same domain as the Polaris domain, you can configure the system to use the external ID
to map the Polaris staff member to the corresponding identity provider user.

Note:
For information about enabling the use of the external ID in
authentication, see the Polaris and OAuth 2.0 with OpenID Connect
Integration Guide.

Adding an External ID to a Staff Member in
Polaris Administration (Staff Client)

To add an external ID to a staff member record in Polaris Administration (staff client)

1. Select Administration > Explorer > Staff Member.
2. Select Search.

3. Search for the staff member you want to edit, and open the staff member record.

4. Enter the external ID in the External ID box. The value must be unique and a max-



What's New in Polaris and Leap 7.5

© 2024 Innovative (Part of Clarivate)
Page 102

imum of 100 characters.

5. Select Save .
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Adding an External ID to a Staff Member in
Polaris Administration (Web-Based)

To add an external ID to a staff member record in Polaris Administration (web-based)

1. From the Polaris Administration (web-based) home screen, select Staff Members.

2. Search for the staff member you want to edit, and open the staff member record.

3. Enter the external ID in the External ID box. The value must be unique and a max-
imum of 100 characters.

4. Select SAVE.
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Enabling a User Inactivity Time-out Period
in Leap
Your library can now enable a user inactivity time-out period for Leap.

Note:
Leap also has a separate maximum session length time-out period of
approximately 24 hours. A Leap user who is signed in must re-
authenticate after 24 hours, or the system automatically signs them out.

To enable the user inactivity time-out period, open a ticket with Innovative Support. In
the ticket, specify the length of the inactivity time-out period you want to use (for
example, 30 minutes).

When the user inactivity time-out period is enabled, Leap displays an Inactivity Timeout
dialog two minutes before the end of the time-out period.

You can select CONTINUE WORKING to remain signed in to Leap or LOGOUT to sign
out. If you don't select either option, Leap closes your session and signs you out when
the user inactivity time-out period elapses.
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MARC Technical Updates in Polaris 7.5
The updates specified in the following links were implemented in Polaris 7.5.

l MARC Technical Notice (January 31, 2022)
l MARC Technical Notice (February 11, 2022)
l MARC Technical Notice (February 28, 2022)
l MARC Technical Notice (March 14, 2022)
l MARC Technical Notice (March 28, 2022)
l MARC Technical Notice (April 15, 2022)
l MARC Technical Notice (April 20, 2022)
l MARC Technical Notice (June 1, 2022)
l MARC Technical Notice (June 14, 2022)
l MARC Technical Notice (June 22, 2022)
l MARC Technical Notice (June 28, 2022)
l MARC Technical Notice (August 16, 2022)
l MARC Technical Notice (August 24, 2022)
l MARC Technical Notice (September 21, 2022)
l MARC Technical Notice (September 27, 2022)
l MARC Technical Notice (October 12, 2022)
l MARC Technical Notice (October 18, 2022)
l MARC Technical Notice (November 15, 2022)
l MARC Technical Notice (December 6, 2022)

https://www.loc.gov/marc/relators/tn220131src.html
https://www.loc.gov/marc/relators/tn220211src.html
https://www.loc.gov/marc/relators/tn220228src.html
https://www.loc.gov/marc/relators/tn220314src.html
https://www.loc.gov/marc/relators/tn220328src.html
https://www.loc.gov/marc/relators/tn220415src.html
https://www.loc.gov/marc/relators/tn220420src.html
https://www.loc.gov/marc/relators/tn220601src.html
https://www.loc.gov/marc/relators/tn220613src.html
https://www.loc.gov/marc/relators/tn220622src.html
https://www.loc.gov/marc/relators/tn220628src.html
https://www.loc.gov/marc/relators/tn220816src.html
https://www.loc.gov/marc/relators/tn220824src.html
https://www.loc.gov/marc/relators/tn220921src.html
https://www.loc.gov/marc/relators/tn220927src.html
https://www.loc.gov/marc/relators/tn221012src.html
https://www.loc.gov/marc/relators/tn221018src.html
https://www.loc.gov/marc/relators/tn221115src.html
https://www.loc.gov/marc/relators/tn221206src.html
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